VisIt is an open source, interactive, scalable, visualisation, animation and analysis tool from LLNLIt can use distributed and parallel environments to work on data defined on two- and three-dimensional (2D and 3D) meshes.

This is just a brief description on how to use it on cx1. Full manuals are available directly from LLNL.

Operational Modes

VisitIt main components are a user interface and a compute engine. By using these VisitIt can be used interactively in several modes:

  • workstation - both user interface and compute engine run on the workstation.
  • client/server - user interface, the client, runs on the local user workstation and the compute engine runs on a remote machine.
  • on a client/"compute cluster" - user interface, the client, runs on the local user workstation while the compute engine runs on a compute cluster using its queueing system capabilities.

On cx1 we only support the last option. Using our logins nodes as your "workstation", the first mode, or as the compute engine, the second mode, is not supported. Running on the login nodes would negatively impact other users.

Client

For all use cases on cx1 you will need to run the client side of VisitIt on your workstation or laptop.

You can download VisitIt directly from LLNL for all common platforms (Windows, Mac, Linux) and follow the installation instructions therein.

The executables you download are the full version of VisitIt and will contain also the compute engine. You may use it for small analyses in your own hardware.

You will need the instructions that follow to use it in the "client/server" and "client/compute cluster" modes, i.e., to run just the user interface on your workstation.  

Client/"compute cluster" mode

In the client/"compute cluster" mode your workstation will run the user interface while the visualization nodes on cx1 will run the compute engine. The user interface on your workstation/laptop will submit a job on cx1 to request a visualization node and this might take some time.

The first time you open your user interface locally on your workstation you will need to create a "Host profile" to connect to cx1. Click on "Options"->"Host Profiles" and then on "New Host". On the "Host Settings" tab fill in the options:

  • "Host Nickname:" ICL-CX1 (you can choose any nickname you like...)
  • "Remote host name:" login.cx1.hpc.ic.ac.uk
  • "Path to Visit installation:" /apps/visit/2.12.2
  • "Username:" <your_IC_login>
  • Tick "Tunnel data connections through SSH"

On the "Launch Profiles" tab click on "New Profile" and fill in the options:

  • "Settings"
    •  "Profile name:" Cluster (you can choose any nickname you like...)
  • "Parallel"
    • Tick on "Parallel launch method" and choose "qsub/mpiexec".
    • Tick on Number of nodes and write 1.

Hit "Apply" and then "Options"->"Save Settings".

You can now use VisitIt with the compute engine on the cx1 visualization nodes.

When you do "File"->"Open file" make sure you choose the correct "Host" (ICL-CX1) from the list. All your files on cx1 should be displayed and you should be able to navigate your directory tree.