designVUE presentation

Click to download a designVUE presentation (pdf format).

designVUE manual

Click to download the designVUE v1.23 manual (pdf format)

Click to download the designVUE v1.04 manual (pdf format)

Changelog

designVUE v1.24
dvlauncher now works correctly in opening invoked vdk files and dvue URLs when designVUE is notalready running

designVUE v1.23
Word wrap now works for IBIS nodes and is enabled by default for newly created maps under 1.23

fixed bug causing error on startup on some Macs with Oracle Java1.7 installed over Apple Java1.6

fixed bad bug causing duplication of unique node Ids when same clipboard content is pastedmultiple times

designVUE v1.22
restored pruning options to View menu in simplified UI mode. These are very useful when youwork out how to use them (read VUE manual!)

fixed bug traversing wormholes where both ends are in the same file

designVUE v1.20
when saving .vdk files, the previous version is always first copied to a file with same name but prepended with .~ as an instant backup in case of an error during the file save

changed split screen mode to display newly opened or hyperlinked map in currently non active pane, so now can easily see both ends of a wormhole simultaneously

fixed bad bug in panToComponent when traversing wormholes

fixed bug silently deleting all lockfiles on application exit, whether owned by current user or not

override stored VUE preferences with hard coded defaults, user changeable by un-commenting lines in system.bsh file

full support for cut/pasting of wormholes between maps

added support for a portable java runtime environment stored in the dvlauncher folder, for situations where the user does not have admin rights to install java on the PC

when a VUE URL resource pointing to a dvue:// url of a node is clicked, the hyperlink is now processed internally rather than passing it to the OS, so it works in situations where designVUE is run from the jar and not installed

implemented DRed-like F5 mechanism to launch dvue:// hyperlink copied to the OS clipboard. Allows hyperlinking to nodes from apps not capable of launching hyperlinks eg standard adobe pdf reader

when trying to find the target vdk file in a dvue:// hyperlink, designVUE now looks for the target filename in each of the folders containing a file of the "recently opened files" list

tab title text of maps for which the user does not currently have edit lock now shown in red as a constant reminder not to edit that map

alt+initial letter short-cuts for creating new elements a la DRed, and if a single existing element is selected then new element is linked to it

new wormhole creation procedure "Copy URL of source node/Paste Wormhole in destination node"

unique IDs of nodes now preserved through cut/paste operation

wormhole nodes now not internally mangled by cut/paste operation

new "Rebuild Wormholes" procedure in File menu for when wormholes have just been cut/pasted into a different map

new procedure on node menus "Copy URL" that copies to the operating system clipboard the node's URL for pasting into an external application hyperlink. It is of the form:

dvue://Power%20window%20switch.vdk#4f5009799bc647b60196563d94c36560

designVUE-beta-v1.08.jar can still be run simply by double clicking it as previously. However to be able to open .vdk files by double clicking them in explorer/finder, and to be able to hyperlink to .vdk files from external applications using file:// and dvue:// URLs, then dvlauncher can be installed:

Detailed list of changes: Changelog v1.08-v1.20

designVUE v1.04

View and import files from DRed

You can now import files that have been exported from DRed, and convert them into .vdk files. You can also view .vdk files that have already been imported.

To import files from DRed, follow these instructions:

  1. Take your *.bsh files, and the "dvimages" folder that were exported from DRed, and put them in the same folder where you are running your designVUE jar file (or vice versa).
  2. In designVUE, select File -> Launch Beanshell console.
  3. When the Beanshell console appears in your browser, type the name of the .bsh file you want to import (for example "a.bsh") and hit return.
  4. A few seconds later, there should be a count in the Beanshell console and an imported map in designVUE.

designVUE по-русскиӣ

Many thanks to Evgeny Volkov, who kindly provided the Russian translation of designVUE. Select Preferences -> Language -> русскиӣ, then close and restart designVUE.