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1 Objectives

This hands-on course is designed to introduce you to Discoverer BI Plus, a database ad-hoc query tool. The first section covers Oracle Discoverer terminology and standard Discoverer functionality. After covering the all Discoverer BI Plus features in a sequential order, this manual concludes with an appendix covering all the functions of the tool.
After completing this course, you should be able to:

· Know how to work with the latest version of this ad-hoc query tool

· Achieve a level of navigational skill and confidence to use the tool to open, create and amend reports to support your business processes.

· Have an insight into the power of online database driven data analysis in comparison to the use of Microsoft Excel

2 Oracle Discoverer BI - Overview

Oracle Discoverer BI consists of the following components, of which most end users at Imperial College will only use the Plus Relational version covered in this manual. Some users will also use Discoverer BI Viewer.
Oracle Discoverer BI Administrator – As with any tool there is an administration version, where support and development of the reporting environment takes place.

Oracle Discoverer BI Plus Relational – (in short Discoverer BI Plus) This version is delivered to your PC through an Internet browser. As the installation and support is running on one web server, the tool can be rolled out many locations simultaneously and does not require additional local maintenance. At Imperial College, Plus is the standard Discoverer tool and depending on your user privileges you can amend, query, save and distribute reports. This manual refers only to this version of the tool.
Oracle Discoverer BI Viewer – This is a read only version that delivers data on an html website. It has limited use beyond running a query and gaining quick access to data. Some users may prefer it to quickly look at or export data.

3 Oracle Discoverer Architecture


[image: image2]
Oracle Discoverer BI is a read only tool for querying databases and any report you create or run will not affect the underlying data that are described in the End User Layer. Therefore, you are encouraged to try things out with the tool and use it for data analysis whenever possible.
Oracle Discoverer Terminology
Item

In Oracle Discoverer terminology, items represent the actual fields of an Oracle Database. In addition, items can also represent calculations on other items from the database. Items available for selection in a report are conveniently located on the Worksheet Wizard Step 2 – Select Items.
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Items can be of two types: textual or numeric. Above items are all of the first type, numeric items are displayed with a blue numeric pad next symbol to the sheet icon. With numeric items, a user can select their aggregation level with the current default highlighted in bold font.
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	Name
	Description

	SUM
	Returns summarised data in case of more than one possible detail line

	COUNT
	Returns the number of rows in the query where the value in the field is not null

	MAX
	Returns the maximum value of this field in that table or view

	MIN
	Returns the minimum value of this field in that table or view

	AVG
	Returns the average value of this field in that table or view

	Detail
	Returns the all the detail values for all possible lines


Folder

A folder represents data from the base tables of the database or from predefined views (restricted data from the base tables). Your Oracle Discoverer Administrator can present the items in folders in a similar way as on a corresponding form in Oracle Financials. Any folder can contain additional calculated items which could assist in the analysis of your reports.
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Folders can be linked by so called joins and with that an Oracle Discoverer Administrator can create connections between items in several folders. If your folders are yellow, you can select items from them, if they are grey, there is no join to the currently selected items. That means that items from the grey folders can not be linked to those items selected on the worksheet.
Business Area (BA)

A Business Area (BA) contains a logical grouping of folders and data. Data in one BA can be linked to data in another BA if the Oracle Discoverer Administrator allows this. Every user has a set of responsibilities in Oracle Applications and this reflects the user’s access to different BAs.
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The End User Layer (EUL) is the actual environment on which you report. It is aimed to hide the complexity of databases from you and lets business users focus on business issues. In the current setup this contains Business Areas covering Oracle Financial modules such as GL, AP or AR as well as Purchasing and all user related data such as security profiles and usage statistics. The Oracle Discoverer Administrator is responsible for making changes to the EUL.

The following graphic shows you how all these components are interlinked.
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Composition of an End User Layer
Structured Query Language (SQL)

SQL is the most popular computer language used to create, modify, retrieve and manipulate data from relational database management systems. Oracle Discoverer generates SQL statements that then query the Oracle database and return the results as your report.
Worksheet

Worksheets are the tabular representations of the SQL query that Oracle Discoverer sends to the database. You can have multiple worksheets in one workbook and the data on these can either have multiple versions of the same data (summary/detail) or contain different data in each worksheet.

This is similar to the principle of worksheets in Excel. For example, a Payable Invoices workbook could have one worksheet detailing all outstanding invoices, with a second showing the total outstanding amount by supplier.
Workbook

A workbook can be a collection of many worksheets and therefore is what is usually referred to as a report.
4 Starting Oracle Discoverer BI 

The start page

As Oracle Discoverer BI Plus is delivered through an Internet browser, your administrators will be able to point you to a start page on your Intranet. You can either add this Intranet page to your favourites or you can follow this link and set this as the Discoverer start page in your browser. It will always require a first log on to the Oracle Applications E-Business suite with a user name and password.
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	Please ensure that you have turned off the Internet Explorer pop-up blocker & that you have selected the Locale ‘English (United States)’. If you are logging in for the very first time, it is advisable to also add ‘discover’ to the End User Layer field as in the screenshot above.


Then you have to select a responsibility, to make use of the existing Oracle Applications security model. Try to select a responsibility that your Oracle user has assigned and which can access the data you want to report on.
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5 Step 1: Create/Open Workbook

This is the first page you see when launching Oracle Discoverer BI Plus.
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Two radio buttons are available for selection:

Open an existing workbook

· allows for selection of recently used workbooks or browsing of available workbooks
Create a new workbook

· allows for the creation of a new workbook through the continuation with the remaining wizard steps

· lets users decide on the layout of their worksheets according to the table below
	Function
	Description

	Title
	Activates the worksheet title area

	Page Items
	Adds a quick hierarchical filter on values of the items that are moved here with drag & drop (highlight an item and hold left mouse button and release)

	Crosstab 

Table 
	Defines the initial layout style for the worksheet

Worksheets have a top and a side axis in a matrix style
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As best practice, workbooks should only contain crosstabs as ‘Summary’ pages for aggregation. It is highly advisable to use standard Table layout for the majority of reports, especially when creating worksheets from scratch.
Worksheets have a single top axis with columns and rows displayed in a tabular format.

	Graph
	Worksheets contain a graph based on the selected numeric items (data points). The drop down menu allows for selection of the graph location on the worksheet.

	Text Area
	This adds an additional text box at the bottom of the sheet. This area can be used for additional comments and notes on the data.


The first workbook wizard step: Worksheet layout represents exactly the same functions as in the table above.
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For the purposes of this end user manual we will continue with opening an existing workbook and cover the steps required for creating a workbook from scratch at a later stage.
Open Workbook from Database

The dialogue box below appears when clicking on[image: image14.png](Browse. |



 in the first dialogue “Open an existing workbook” area. Alternatively, you can always navigate to open an existing workbook by following the path below:
(N) File > Open…
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This is a list of all available workbooks for this user and the selected responsibility.
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	As this list will grow over time through sharing of workbooks and additional standard workbooks provided to you, it is highly advisable to provide telling names and good descriptions for each workbook and to apply a naming convention, such as prefixes like “PUR” for Purchasing or “GL” for GL reports.
Also bear in mind that in Discoverer Plus you can only ever have one workbook open at any one time.


It is possible to filter the available workbooks by clicking on the drop down next to [image: image17.png]® OracleBl Discoverer
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Filter by Workbook Type

This provides a filter for all self-created workbooks, database workbooks and scheduled workbooks.
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Filter by User

[image: image19.png]pen Workbook from Database

Choose a target worksheet by browsing avallable workbooks and selecting a workshet

vew: (Ao =) (B =] o corieos: ] (cear)
Ytk
eno = s

D Fntran Dis Nov 1, 2006 10:41 A

 Fntranzois Nov 1, 2008 12:54 P

@ OMS._Generel_Award_8_Project Detals Aug 17, 2005 522 P

R GMS_Prject Closing_Belances Sep 1, 2005 1208 i

S RS Profect_Summary_Report g5, 2008 614 P
© GHSIL Reconciston Excetian Rt A 25, 2005113 P
 GHS - Award Revenue CostCerire M. Apr7,2008 509 I
RN It on User Warbooks Jen 25,2005 521 P
& oscover

Description





On the next button it is possible to filter the available workbooks even further by workbooks, individual users, or tables used. The graphic shows the individual users (User Tree).
Search Workbooks

The Search field allows for workbooks to be searched by Name.
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	The list will be filtering workbooks while you type in your search term.


Delete Workbooks
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After highlighting a Workbook that you own (in this case ‘DISCOTRAIN’), you can delete this workbook at any time by using the ‘Delete’ key on your keyboard. Alternatively use the context menu with a right click.
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	You should make sure that you do not delete any of your saved workbooks that you have shared with others before getting their approval that the workbooks is not needed any longer.


Sorting within Open Workbook dialogue

It is possible to sort within the open workbook dialogue by left clicking on one of the column headers. This will trigger an arrow pointing upwards or downwards depending on the applied sort direction.
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Sort workbooks by owner

Basic navigation

The navigation in Oracle BI Discoverer is best explained with an opened report and with data available on screen to explain all functions and options.
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	It is highly recommended for most users to use existing workbooks and amend them according to your analysis. It is always easier to rearrange an existing query than to start a report from scratch.


The work desk
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Oracle BI Discoverer presents data in a familiar tabular format and uses a graphical user interface that is familiar from Microsoft Windows Applications. In addition some views (panes) are available to speed up certain report writing processes. It is possible to enable/disable each element on the work desk via the toolbar function View.
6 The Workbook Wizard

Oracle Discoverer BI Plus is a tool for business users to hide the complexity of the database from non-technically focused users. To create a database query, i.e. a report, from scratch, Oracle Discoverer BI Plus uses a so called workbook wizard that takes a user through 5 steps. 
Step 1: Create/Open Workbook

In this step, you can select from existing Workbooks provided by the Oracle Discoverer Administrator or other users 

Step 2: Select Items

This step is used to select the items for your query, filtering them by using conditions or to add new items using calculation.

Step 3: Table Layout

Here you define the layout of the results on screen.

Step 4: Sort

Here you set the order of the item values.

Step 5: Parameters

Here you define filters that are set in front of the query to limit the data on the worksheet.

Apart from step 1, the remaining 4 wizard steps are covered in detail in the following chapters of this manual.
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	Some Discoverer functions revisit a wizard step again and then use buttons unavailable in the initial workbook wizard steps. 

Therefore the following logic applies in this manual: first all workbook wizard steps are explained as if a new report is created. Then the detailed functionalities of the worksheet wizard are explained which are used mostly in the report analysis stage.


7  Amending and analysing an existing report

The logical order of the Workbook Wizard steps resembles a constant data filter through which Oracle BI Discoverer leads a business user to a final workbook.
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8 Worksheet Wizard - Step 2: Select Items

(N) Edit > Worksheet…> Select Items
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The functionality described below can also be accessed via the Selected Items Pane (if displayed).

The Selected Items dialogue box is divided in two boxes: ‘Available’ and ‘Selected’. In the first instance this refers to Items (see highlighted tab), in later screens also to the other tabs Conditions and Calculations.

First we look at the components of this screen:
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1
Drop down menu showing all available Business Areas

2
Find – Search for Items or Folders by name

3
Drop down menu allowing to switch view: with or without Folders, with Folders shown here

4
Folders. Linked folders shown in yellow, not linked Folders shown in grey

5
Different functions for what to do with items, conditions or calculations

Available - Business Area

A left-click on the Business Area drop-down list shows all available Business Areas for selection of items. The amount of Business Areas available depends on the security levels set up for your user name and the responsibility selected. 
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	If you feel that your workbooks could benefit from additional data, please ask your Discoverer Administrator after searching for missing items yourself.


Available – Folders

Yellow coloured folders contain items that are joined to each other by the Discoverer Administrator. You can select and add any of these items to your worksheet by highlighting them with one left click and either dragging and dropping to the Selected box or clicking on the Right arrow in the middle between the two boxes.

Available - Find

The find option enables a user to search for items or folders using the dialogue below.
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It is possible to search in Business Areas, by search expressions such as
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and for specific terms, such as ‘Supplier’ in the example above. After results are retrieved, it is possible to sort any column by clicking on a header, such as on ‘Name’ in the example above.

Selected - Change View
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In the ‘Selected’ box the Folders can be shown or not using ‘Show’ or ‘Hide’.

Selected Items Toolbar

All the functions, which are available in the Worksheet Wizard - Step 2 Selected Items are also available via a Selected Items Toolbar in the Selected Items Pane on the main work area or for conditions and calculations via the Menu bar clicking on Tools>Conditions or Tools> Calculations.
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	Use this button to remove the item currently selected in the Selected Items pane from the worksheet.
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	Use this button to edit the item currently selected in the Selected Items pane. This button is unavailable (grey) for read-only items created by the Discoverer Administrator.
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	Use this button to display the Show Condition dialog, which enables you to view details of the currently selected condition. This item is active for read-only conditions created by the Discoverer Administrator in specific Folders. You cannot edit or delete conditions created by the Discoverer Administrator.
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	Use this button to remove the currently selected item from the worksheet. This button is unavailable for read-only items created by the Discoverer Administrator.
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	This button indicates that folders are not shown in the item list below. Use this button to change the list style from Hide Folders to Show folders.




Functions – Conditions

When you click on New, you can create additional items, conditions or calculations.

Switching the Tabs above the Available box from Items to Conditions reveals all available conditions on the workbook.

Conditions are filters that are applied when querying the database to limit the amount of data brought back to a user. This is done to decrease the complexity of the query and increase the speed and efficiency to facilitate the workbook analysis.

Conditions can be created and enables/disabled via a tick box. They can also be provided by the Discoverer Administrator on an optional or mandatory basis in specific Folders. That mode enables a business user to create complex conditions that might be applicable in one Folder and that could be reused by other users of the same Folder in their query.
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When holding the mouse over a specific condition, the formula is displayed with a mouse over dialogue, as in the example above. To enable a condition, simply select it and drag it to the ‘Selected’ box (see invoice Number above).
New/Edit Condition

The principles for creating new and editing existing Conditions are very similar and both use the same dialogue. Therefore the examples below cover the creation of a new condition only.
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This screen is structured as follows:

	Function
	Keyboard Shortcut
	Description

	What would you like to name your condition?
	Alt+N
	If the tick box generate name automatically is unchecked, you can provide a meaningful name for this condition. Otherwise the formula generated by the condition appears here.
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It is best practice to use automatically generated names for simple conditions, as the filters in the Worksheet Wizard Step 2 - Select Items > List allow for selecting conditions based on the items they use. Renaming conditions removes this straightforward connection and can confuse users new to a workbook.


	What description would you like to give your condition?
	Alt+S
	Here you can provide a meaningful description for any of the descriptions on the worksheet. This might facilitate reuse at a later time.

	Formula
	---
	Here is where you actually generate or edit the condition.

	Case sensitive
	---
	Matches the value exactly as input.

Note: It is best practice to leave this box ticked and to always enter the exact values if known. Disabling this box can lead to big losses in query efficiency and lead to long waiting times for results.




Condition Formula

Conditions consist of three elements:

Items
The actual Items the filter is based upon. This can be an actual database item, a calculation or another condition.

Condition
This is the actual operator to filter the Item. The following options are available.

	Operator
	Description

	=
	Equals exactly one value, i.e. Account = ‘12345’

	<>
	Is not this value, i.e.  Account <> ‘12345’

	>
	Is larger than the value, i.e. Amount > 1000

	<
	Is less than the value, i.e. Amount < 1000

	<=
	Is less or equal the value, i.e. Amount <= 1000

	>=
	Is larger or equal the value, i.e. Amount >= 1000

	LIKE
	Matches the value or partial value, i.e. Location LIKE ‘Glasgo%’. Wildcards can be used to replace single digits ‘_’ or ‘%’ for unknown number of digits.

	IN
	Equals more than one value, i.e. Location IN (‘Manchester’, ‘Glasgow’, ‘Liverpool’)

	IS NULL
	Item does not contain values, i.e. Ship Qty IS NULL – no shipment has taken place

	IS NOT NULL
	Item contains values, i.e. Ship Qty IS NOT NULL – something must have been shipped

	NOT IN
	Filters exactly these (more than one) values, i.e. Location NOT IN (‘Manchester’, ‘Glasgow’, ‘Liverpool’)

	BETWEEN
	Filters for a range, i.e. Amount BETWEEN ‘100’ AND ‘1000’

	NOT BETWEEN
	Excludes this range, i.e. Amount NOT BETWEEN ‘100’ AND ‘1000’

	NOT LIKE
	Excludes matches of this values or partial value, i.e. Location NOT LIKE ‘Glasgo%’. Wildcards can be used to replace single digits ‘_’ or ‘%’ for unknown number of digits.

	!=
	Similar to <>, only used for querying different databases


Value

This is the actual value to filter the Item. The following options are available.

[image: image43.png]x

What woull you ke to name your condtion?

[(Opering Batance » 15000) | 4 Generate name automticaly

it desertion wouk yu e o ive your contion?
[ ]

Formula
Type anumerc value o sslecta value fromhe dfop-down st Mulple values must be separated by commas

ttem Conditon Values
|List of Belances Opening Balance - |[15000 -1 R
(Create Calouition.. R
ISt Htom.
bow Parameter...

Case-sensiye

This canditian s lacated nthe workhook  FinTraint DIS'

Cancel

Help





You can type in values (as in this example ‘15000’), if multiple values are needed, separating them by comma; or create calculations, select other items or create/add parameters.
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You can setup new conditions straight from the Table area by highlighting (left-clicking) the column that should be filtered. Then you need to click on the toolbar icon for condition (here including a shortcut to the operators on the downward black arrow) and the column will be automatically entered into the Item box.


Advanced Conditions

Advanced Conditions combine single purpose conditions using the operators AND, OR, NOT AND or NOT OR. With this is possible to create fine tuned conditions to filter out exactly the results required.
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	It is best practice to create one component condition of such advanced Conditions at a time, to run & test it and then add additional components one-by-one. It is also advisable to name these conditions properly and describe their purpose. If the condition is particularly useful on one workbook, it might be a good idea to turn it into an optional condition on a Folder in the EUL, thereby allowing other Discoverer users to reuse it automatically on their worksheets when they select items from this folder. Contact your Discoverer Administrator for registering conditions to the EUL.
It is possible to create a number of excluding conditions and run them at the same time. Therefore it is highly advisable to check/uncheck conditions carefully and for Beginners to check/uncheck one at a time.


Delete Condition

After selecting a condition it is possible to delete it from the workbook following the instructions in the dialogue box.
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	It is always advisable to check if it might be enough to simply disable a condition, as the potential reusability of a condition disappears when it is deleted. It might be better to just change values or create an additional condition preserving an existing condition for later use.


Calculations

Calculations are items that are calculated using available or selected items and applying additional mathematical or database operations to them.

Calculated items appear just as any other item as columns in the worksheet. Use the Available box to select and move additional calculations to the ‘Selected’ box.
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You can also select and edit or delete a calculation.
New/Edit Calculation

The principles for creating New and Editing existing Calculations are very similar and they use the same dialogue. Therefore the examples below cover the creation of a new calculation only.
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When you click on New - New Calculation, you see the following dialogue.
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The table below shows how you can create a calculation.

	Element
	Description

	What do you want to name this calculation?
	Here you can provide a telling name, which will also be the item label on the worksheet column.

	Show:
	Lists a number of options for Items to add to the calculation

	Calculation Box
	Area for composing the formula of the calculation

	Insert Formula from Template
	Some standard calculations available as Templates for quick selection

	Operators
	Mathematical and database operators to add to the calculation. It is also possible to type these directly into the calculation box.




Show:
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	Element
	Description

	Functions
	It is possible to use any of the number of embedded functions in the tool, which are similar to any Excel function that is following the ‘=’ in a Cell.

	Selected Items
	You can use Selected Items from your workbook

	Available Items
	You can use Available Items that are linked to the currently selected items in your workbook.

	Calculations
	You can use previously created calculations

	Parameters
	You can use parameters
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	Parameters make excellent variables for ‘What if?’ type calculations, for example Budget % increase/decreases: Budget *(Parameter/100)


Example Calculation

In the above example the variance of the current Actual Period Amount to the Previous Period Actual Amount is calculated.

Calculations can be reused, checked and unchecked in a similar form as conditions. They can also be registered in the EUL, for example to implement certain regularly occurring calculated items such as complex algorithms and Key Performance Indicators via the database.
Delete Calculation

After selecting a calculation it is possible to delete it from the workbook following the instructions in the dialogue box.
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	It is always advisable to check if it might be enough to simply disable a calculation, as the potential reusability of a calculation disappears when it is deleted. It might be better to just change some values or create an additional calculation preserving an existing calculation for later use.


Useful Functions
The most powerful feature of Discoverer is to calculate items from functions. Find below some of the most useful functions and feel free to explore them for yourself (baring in mind Microsoft Excel and the options available after putting an ‘=’ in a cell).

Date Functions
	Function
	Syntax
	Description
	Example
	Result

	ADD_MONTHS
	ADD_MONTHS(date, number of months)
	Will add a complete number of months onto the provided date.
	ADD_MONTHS (’21-OCT-04’,2)
	21-DEC-04

	MONTHS_BETWEEN
	MONTHS_BETWEEN(date1, date2)
	Will calculate the number of complete months between two dates.
	MONTHS_BETWEEN (’21-OCT-04’, ‘10-JAN-05’)
	9

	TRUNC
	TRUNC(date, ‘format’)
	Truncates the date to the picture provided.
	TRUNC (’21-OCT-04’, ‘YYYY’)
	2004

	SYSDATE
	SYSDATE
	The system date will be returned
	SYSDATE
	21-OCT-04


Group Functions
	Function
	Syntax
	Description
	Example
	Result

	MIN
	MIN(item)
	Where a number of records are grouped together, this funciton will return the minimum value.
	MIN(profit)
	0.12

	MAX
	MAX(item)
	Where a number of records are grouped together, this funciton will return the maximum value.
	MAX(profit)
	£125

	AVG
	AVG (item)
	Where a number of records are grouped together, this function will return the average value
	AVG(profit)
	£11

	SUM
	SUM (item)
	Where a number of records are grouped together, this function will return the sum of all the values
	AVG(profit)
	£1520

	COUNT
	COUNT (item)
	Where a number of records are grouped together , this function will count all the non null values.
	COUNT (profit)
	154

	COUNT_DISTINCT
	COUNT_DISTINCT (item)
	Where a number of records are grouped together, this function will count one occurrence of each value, even when duplicated a number of times.
	COUNT_DISTINCT(profit)
	174


Numeric Functions

	Function
	Syntax
	Description
	Example
	Result

	ROUND
	ROUND(value, decimals)
	Rounds the provided values to the given number of decimals.
	ROUND(12345.45645, 1)

ROUND(12435.45645, -1)
	12435.5

12440

	TRUNC
	TRUNC(value, decimals)
	Truncates, or ignores digits outside the given number of decimals.  Truncating to a negative value will ignore significant figures to the left of the decimal
	TRUNC(12345.6789, 1)

TRUNC(12345.6789, -1)
	12345.6

12340


String Functions
	Function
	Syntax
	Description
	Example
	Result

	UPPER
	UPPER(TEXT)
	Will return the text value all in upper case
	UPPER(‘Text’)
	TEXT

	LOWER
	LOWER(TEXT)
	Will return the text value all in lower case
	LOWER(‘Text’)
	Text

	INITCAP
	INITCAP(TEXT)
	Will return the text with the first letter of each word in upper case the rest in lower case
	INITCAP(‘this is a text item’)
	This Is A Text Item

	CONCAT
	CONCAT(value1, value2)
	This function allows two values to be joined together to create one return string
	CONCAT(‘Customer Name =’, ‘JONES’
	Customer Name = JONES

	LENGTH
	LENGTH(text)
	This will count the length of a string
	LENGTH(‘This is a text string’)
	21

	LPAD
	LPAD(text, width, string)
	Pads the string to the left to the width provided and the places the string in each space
	LPAD(‘String’,10, ‘x’)
	xxxxString

	RPAD
	RPAD(text, width, string)
	Pads the string to the right to the width provided and the places the string in each space
	RPAD(‘String’,10, ‘x’)
	Stringxxxx

	REPLACE
	REPLACE(text, search string, replace string)
	This will replace any occurrences of the search string in the text with the replace string.  If the replace string is null the search string will be removed
	REPLACE(‘GEORGE’, ‘GE’, ‘XY’)

REPLACE(‘GEORGE’, ‘GE’, NULL)
	XYORXY

OR

	SUBSTR
	SUBSTR(text, start point, number of characters)
	This function will return a section from a text string string at the start point and ending after the number of characters defined.   If the last argument is not defined the remainder of the string will be returned
	SUBSTR(‘abcedfghijkl’, 4, 5,)
	defgh

	TRANSLATE
	TRANSLATE(text, search, replacement)
	This function will search for values and replace them with other values
	TRANSLATE(‘ABCDABCDABCD’, ‘A’, ‘X’)
	XBCDXBCDXBCD

	INSTR
	INSTR(text, search, start, occurrence)
	This function will return the start point of a search value in a text string for a particular occurrence
	INSTR(‘Peter piper picked a peck of pickled pepper’, ‘pi’, 1, 1)
	7


Other Functions

	Function
	Syntax
	Description
	Example
	Result

	NVL
	NVL(value, replacement)
	Allows hull values to be altered to contain a value.  Dates must be replaced with dates, text with text and numbers with numbers
	NVL(postcode, ‘Not Found’)
	Not Found

	DECODE
	DECODE(value, check value1, substitution value1, check value 2, substitution value2….……….check valueN, substitution valueN, default value)
	Decode is the most powerful of the functions available.  It will let you search and replace or alter any number of values.  The ‘value’ item is checked for each one of the ‘check values’ and substituted appropriately
	DECODE(Region, ‘Central’, ‘A’, ‘East’, ‘B’, ‘C’)
	Central = A

East = B

Everything else = C


Percentages
Once a worksheet contains data points (items with a numeric data type) it is possible to create percentages using the Worksheet Wizard – Step 2 Select Items screen or Tools>Percentages.

On the Edit Worksheet Wizard, click on New>Percentages to get to the following screen.
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These are the elements of the Percentage dialogue.

	Element
	Description

	What do you want to name this percentage?
	Here you can provide a telling name, which will also be the item label on the worksheet column.

	Generate name automatically
	This will use the formula that is applied for calculating the percentage and the item it is based on.

	Which data point do you want to base your percentage on?
	Here you have to select a data point (an item with numeric values)

	Calculate as percentage of
	You can select a grand total or subtotals, in above example the percentage is calculated as a subtotal for each Costcentre.

	Do you want to calculate percentages within each page
	You can decide to calculate percentages for the currently displayed page or, if applicable, across all pages.



	Example
	This provides you with a graphical representation of your selections

	Which totals do you want to be shown?
	Here you can label the percentage using text or on the drop down select database functionality (Item name or Data Point name or Value) for the percentage label

	Format Data
	You can format the display of the percentages you create using the format dialogue.


Delete Percentage

After selecting a Percentage it is possible to delete it from the workbook following the instructions in the dialogue box.
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	It is always advisable to check if it might be enough to simply disable a percentage, as the potential reusability of a percentage disappears when it is deleted. It might be better to just change some values or create an additional percentage preserving an existing percentage for later use.


Totals

Once a worksheet contains data points (items with a numeric data type) it is possible to create totals using the Worksheet Wizard – Step 2 Select Items screen or Tools>Totals.

On the Edit Worksheet Wizard, click on New>Totals to get to the following screen.
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	Element
	Description

	Which item would you like to create a total on?
	Here you can select any item that is a data point (an item with numeric values)

	What kind of total do you want?
	You can chose from a number of options such a SUM (the most common total), COUNT (a count of occurrences) or statistical calculations such as averages, means etc.

	Where would you like your total to be shown?
	You can select a grand total at the bottom of the page or subtotals at specified changes in item values.

	Don’t display total for a single row
	If the total would be based on a single row it is possible to not show a total to prevent duplication.

	Do you want to calculate totals within each page
	You can decide to calculate totals for the currently displayed page or, if applicable, across all pages.



	Example
	This provides you with a graphical representation of your selections

	Which label do you want to be shown?
	Here you can label the total using text or on the drop down select database functionality (Item name or Data Point name or Value) for the total label

	Generate label automatically
	This will label the total ‘Sum’

	Format Data
	You can format the display of the percentages you create using the format dialogue.


Delete Total

After selecting a Total it is possible to delete it from the workbook following the instructions in the dialogue box.
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	It is always advisable to check if it might be enough to simply disable a total, as the potential reusability of a total disappears when it is deleted. It might be better to just change some values or create an additional total preserving an existing total for later use.


9 Worksheet Wizard - Step 3: Table Layout

 (N) Edit > Worksheet…> Table Layout

With Table Layout you can change the look and feel of the worksheet. You can navigate here using above path, clicking on Edit>Table Layout or the icon in the toolbar.

[image: image58.png]To change the layout of informtion in your worksheet, cick an crag the column hescings tothe location you wart. To change format
seftings, clck the Propertes... bufton.

[ Show Page tems| (] Hide Duplicate Rows
Page tems:
Level 1 Costcentre | Costeentre Desc | Analysis | Opening Balance | Actual Previous Periods | Actual This Peri
1
2
3
4
5
[
7
8
g
10
1"
12
< I D]

poperties.| [ snowset. | [0 [ caa |





	Element
	Description

	Show Page Items
	Ticking this allows for a quick filter on one or more items that are moved here by drag and drop.

Note: Do not use Page Items too extensively. Any filter of three or more items might slow down the data retrieval and display on your worksheet as all the values will need to be fetched and sorted in the working memory of the PC. Depending on your machine specifications this might take longer than expected.



	Hide Duplicate Rows
	Sometimes queries produce duplicate rows on a worksheet. If this behaviour is not wanted, this tick box will remove the duplicates.

	Table
	A column is moved by left-clicking and holding the mouse button and then moving it to the desired position. You can only move one column at a time. 


Duplicate as Table 

A Worksheet can be copied by using the Edit > Duplicate Worksheet…> as Table functionality.

You will be taken to the Table Layout screen of the Worksheet Wizard – Step 3, where you can make amendments to this copied worksheet. 

Clicking OK will then produce a new worksheet labelled with the name of the copied worksheet and an additional ‘(2)’. You may want to rename this sheet according to its purpose in your workbook.

Crosstabs

Crosstabs are a way of showing summarised data in a matrix or pivot format.

A Crosstab can be created by duplicating a table as a crosstab or by creating a new worksheet through the worksheet wizard.
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	It is highly advised to always start with a plain normal table and when happy with the displayed results move this to a crosstab via ‘Duplicate as Crosstab’.


Duplicate as Crosstab

(N) Edit > Duplicate Worksheet…> as Crosstab

Initial Warning
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This warning is quite normal and refers only to the display properties of the Items. Most Items by default have a display property of ‘Top Axis’ and this can only be changed by the Discoverer Administrator.

You can simply move the top Axis Items that should be ‘Side Axis’ Items via drag and drop and then click OK.
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	Make sure that you always have at least one data point in the central area of the Crosstab as these Items provide the values.


It is also possible to duplicate in the opposite direction as a Table from a Crosstab.

10 Worksheet Wizard - Step 4: Sort

(N) Tools > Sort
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The Worksheet Wizard Step 4 Sort allows for specifying the order of the values on a worksheet. It consists of 4 options:

1. Column
The Item that should be sorted

2. Direction
The direction of the sort, either ascending (Low to High) or descending (High to Low)

3. Sort Type
Here you can ‘Group Sort’ an Item (for example for later sub-totalling) or leave at the default setting ‘Normal’
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	Group sorted items take precedence over Normal sorted Items. When dragging a Normal sorted Item above a Group Sorted Item this rule results in the Normal sorted Item to automatically become Group Sorted.


4. Hide

You can add Items into a sort but do not need to display it on the actual Worksheet.
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	Do not add too many hidden Items to your query as this can be confusing for users and can make the query inefficient, i.e. slow.


It is possible to Sort as many Items as you have selected on your worksheet by clicking on Add.
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	It is best practice in a Western setting to display the Items on a sheet in the same order that they are sorted in.


You can also delete Items from a Sort by clicking on Delete. Moving Items, i.e. changing their order, is best achieved by drag and drop on the left blue area right of ‘Sort By:’.

11 Worksheet Wizard - Step 5: Parameters

(N) Tools > Parameters

Parameters are used to publish workbooks for re-use by others or at a later stage. They are conditions that are set to limit the query before it is run.
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In this example we amend a Parameter for CID by clicking on Edit. 

The concept for the creation of a Parameter is following the same process and works on the same screen on the ‘New…’ button.

	Element
	Description

	What do you want to name this parameter?
	Here you can chose a useful name for the Parameter.
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It is best practice to label Parameters for ranges ‘Start’ or ‘End’, for example ‘Start Date’ or ‘End Date’.


	This parameter is based on the item named:
	You can select from all selected items on the worksheet. When you are editing a Parameter, you cannot change the item.

	What prompt do you want to show for this parameter?
	This is the label of the Parameter for the users on screen. You should be very specific and provide an example of the data expected from the user.

	What description do you want to show for this parameter?
	Here you can provide more text to make it absolutely clear what this Parameter aims to achieve.

	Do you want to allow different parameter values for each worksheet?
	You can chose to always use one set of values for all worksheets or different values in each worksheet.

Note: It is best practice to use the default setting: one set for each worksheet, as different values in each worksheet might confuse users.

	What properties do you want to give this parameter?
	You can select if one value is to be entered or if multiple values can be entered. Additionally, if set by the Discoverer Administrator for the base item, indexes or values can be used.

	Require users to enter a value
	With this option you can make parameters optional or mandatory. It is highly advisable to have at least one or two mandatory parameters to make user queries more distinct and faster.

	Enable users to select either indexes or values
	If available, this option allows for usage of identifiers to retrieve lists of values. In the best case this would shorten the display of a list of values.

	What default value do you want to give this parameter?
	If enabled by the Discoverer Administrator, a list of values can be used. Alternatively you may want to add one default value manually, i.e. in this example ’AA’.

	Do you want to filter the list of values for this parameter?
	Here you can either show all values available or add a condition to filter the available values.


Delete Parameter
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	Similarly to Conditions, Calculations, Totals and Percentages, Parameters may be enabled or disabled and do not need to be deleted.


12 Format Data
(N) Format > Data… or (N) Format > Item Formats…

Selected (highlighted) data can be formatted using above navigation path or the context sensitive navigation (right-click) on a table cell. The following dialogue will open:

[image: image70.png]Tox | Breats |
T —
sy B] ¢ ][u][s]

Color
Text

Background:

Algnmert

=EE=E=E

(] wrap words in cel

Example:

stz





Format Tab

	Element
	Description

	Font
	You can select any font that is installed on your PC.

	Size
	A range of font sizes is available.

	Style
	Bold, italics, underlined and strikethrough are your options

	Color
	Allows for a choice of colours according to user selection for text and background

	Alignment
	You can choose to align text with a left, centralized or right orientation, as well as apply the default property supplied with the item. On the right hand side you can chose the display within the cell – top, centralized or bottom

	Wrap words in cell
	Any content can be word wrapped according to the width of the column.

	Show actual font size
	You can choose to display the selected font size in the Example box.


Text Tab

As indicated previously different data types are available for selection. Depending on the datatype of the item either Text, Number or Date is displayed in the second tab of the format dialogue.
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	Categories
	Description

	None
	Displays data exactly as stored on the database.

	Default
	Displays data as per the setting of the Discoverer administrator.
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Sometimes data types do not match the content of the data (i.e. a wrongly allocated text data type to a date or a number). Please contact your Discoverer Administrator to change that data type on the EUL.


	Text
	You can display Text as UPPERCASE, lowercase or Capitalized.


Date Tab
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	Categories
	Description

	None
	Displays data exactly as stored on the database.

	Default
	Displays data as per the setting of the Discoverer administrator.
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Sometimes data types do not match the content of the data (i.e. a wrongly allocated text data type to a date or a number). Please contact your Discoverer Administrator to change that data type on the EUL.


	Date
	Select from the provided list which date style suits your needs.

	Time
	If recorded & required, add a time stamp to your date item.

	Custom
	Set your own custom format following the provided syntax & examples shown in the box below. When you edit a custom format, you can add it (& subsequently delete it) to your list of custom formats using the buttons on the right hand side.


Number Tab

[image: image75.png]Categories:

Nore Decimal Places: [0 =)

Defautt

B

Currency Negative Nurmbers:

Percert
Sclertific
Custom

Example:





	Categories
	Description

	None
	Displays data exactly as stored on the database.

	Default
	Displays data as per the setting of the Discoverer administrator.
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Sometimes data types do not match the content of the data (i.e. a wrongly allocated text data type to a date or a number). Please contact your Discoverer Administrator to change that data type on the EUL.


	Number
	Set the number of decimal places displayed, if you want to use a thousand separator as well as the way you want to have negative numbers appear on the worksheet.

	Currency
	Set the number of decimal places displayed, which of the 4 standard currency symbols (£, $, € or ¥; or no symbol) as well as the way you want to have negative numbers appear on the worksheet.

	Percent
	Set the number of decimal places displayed as well as the way you want to have negative numbers appear on the worksheet Set the number of decimal places displayed.

	Scientific
	Set the number of decimal places displayed.

	Custom
	Set your own custom format following the provided syntax & examples shown in the box below. When you edit a custom format, you can add it (& subsequently delete it) to your list of custom formats using the buttons on the right hand side.


Break Tab
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If you have a group sorted item selected, you can decide on the display style using the following options:

	Element
	Description

	Line
	Select the thickness of the line break required as well as the line colour.

	Blank Row
	Enter the number of blank rows required between the groups.

	Page Break
	Turn each change in the grouped values into a page break (for printing).


13 Format Heading

(N) Format > Heading… or (N) Format > Item Formats…

Headings can be formatted in a similar style to data.
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	Element
	Description

	Font
	You can select any font that is installed on your PC.

	Size
	A range of font sizes is available.

	Style
	Bold, italics, underlined and strikethrough are your options

	Color
	Allows for a choice of colours according to user selection for text and background

	Alignment
	You can choose to align text with a left, centralized or right orientation, as well as apply the default property supplied with the item. On the right hand side you can chose the display within the cell – top, centralized or bottom

	Wrap words in cell
	Any content can be word wrapped according to the width of the column.

	Show actual font size
	You can choose to display the selected font size in the Example box.


14 ITem formats - Edit Heading

(N) Format > Item Formats…

Item Format allows for the selection of similar item types (only numbers, only text items, or only date items) and a wholesale change on the Heading/Data formats as per the options explained above.
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In addition, there is an Edit Heading button, allowing for the editing (changing) of heading labels on a worksheet.
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	Make sure that the label chosen for the worksheet does not remove the item from its actual data context. If an item is labelled incorrectly on the EUL it is necessary to contact the Discoverer Administrator and request a change for this item.


15 Conditional Formatting

(N) Format > Conditional Formats…

Conditional Formats are visual representations of conditions according to user defined sets. They are useful to highlight exceptions in the data that should grab the attention of a user instantly when looking at a report.
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Clicking on New yields the following dialogue. In this example a range of result should be showing in Orange colour.
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Clicking OK will bring you back to the selection screen. 
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	Note the option to have a conditional format active or inactive at any one time. There is little need to delete conditional formats, as they can always be amended should different values or formats be required.


The screen below shows the results of the selected conditional format.
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16 page Setup
(N) File > Page Setup…

Page setup works along a set of tabs starting from the worksheet tab.
Worksheet tab
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You can set the desired Paper Size, the Orientation on the print out, if you want to print a Title on the first or every page, if you want to print the Text Area and where (provided you have the Text Area populated).

Table tab
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Here you can decide the order of columns on the page as well as set some scaling parameters.
Margins tab
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The Margins tab lets you chose the preferred unit format (Pixel, Inches, cm) and the preferred margin sizes for a print out.
Header/Footer tab
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Each of the Header/Footer boxes lets you enter free text or insert the database objects as per the drop-down menu. In addition you can set border lines & fonts with their specific colours if required.
Preview
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On the preview screen you can get a feel for how the page will look when printed.
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	It is recommended to set up a specific print sheet with all the necessary formats & font sizes for regularly printed output.


17 Print

(N) File > Print…

The print dialogue lets a user chose if the complete workbook needs printing or only the current sheet. If a graph is available you can select between Table or Graph to be printed. Page Items can be used as page breaks.
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18 Export Data

(N) File > Export…
The Export Wizard can be accessed using above navigation path. Alternatively, direct exports to HTML and Excel can be started using the options below the ‘Export…’ Wizard.
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The following screenshots take you through a structured export.

First you can select if you want to export parts, or the whole workbook.
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Clicking Next lets you choose a name for the exported file and a location (Browse) on your hard disk or network drive. You can decide in which file format you want to export the data – simply click on the drop down list next to ‘Table:’.
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	When choosing a file name, you need to follow the Microsoft naming conventions and cannot use special signs such as ‘,’ or ‘;’ etc.


Depending on whether you have Parameters in your report or not, you have to select a Parameter in step 3.
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	If you have the need for exporting multiple files this step can actually shorten the time it takes to run the exports – simply repeat the steps for each Parameter Value needed & produce exports without the need for running a query each time.
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The final step is only to choose control over the export process or let Discoverer run automatically.
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Independent from any selection Discoverer will come up with an Export Log after clicking ‘Finish’.
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19 Using Drill-UP/Drill-Down

Drill-ups and Drill-downs allow for advanced navigation within a query along predefined navigation paths (or hierarchies) setup by the Discoverer Administrator.

You can access Drills via the following three options:

Wherever you see an arrow pointing to the left of a column name you can left-click on the header to display possible drill paths.

[image: image102.png]e E vew Fams Ios ek
CVOSE B.-DMd 9 = % % & % & &
oo ~]o [¥) B £ U L2y BB B

2 oM DHZAD-Education DI Activity 000 743 52850 ) 7967

3 oM DHZAD-Education D Anlysis 000 E3 2400 E3 270

W o onzaDEdueaton o prano reed o

a3 o DHZAD-Education  DHZAD. 0.00 2747 0.00 o 2747 At
Double-sick here o ait e text area
[ sheet 1

#sta| @ (0] (3 ) SeachResuts | (L) MyDocuments | [O] Calendar-Micto.. [ # Internet E... - ] Oracke Discover..| ] Time Sheat_Mi. | * G| [« & 2 O] 1339





Right-click on a column header, wherever you see an arrow pointing to the left of a column name, and navigate to ‘Drill…’.
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Or via the Menu bar clicking on ‘Tools > Drill…’
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The ‘Drill…’ dialogue displays the available drill path:
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And the Advanced button enables further options for the drill function relating to the required action – to expand the sheet with the new item, to replace the current item or to place the drill results in a new sheet.
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20 Graphs

(N) Edit > Graph…
Similar to the powerful presentation options in Microsoft Excel, graphs in Discoverer work according to a set of wizard steps. In this version of the tool, graphs have been greatly improved and you may try and use them for dynamic creation of graphs based on you retrieved queries.

Edit Graph – Type
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All the usual graph types are available for selection in Discoverer BI Plus.

Edit Graph – Style
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The different styles available make graphs look more professional as they apply a homogeneous colour scheme throughout the Title Area, Axis & Legend headings as well as the plot area. Here ‘Earth’ was selected.

Edit Graph – Titles, Totals, and Series
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In this tab you can select to show a Graph title and set the display of the content components. If you include series in a graph you can chose the series direction using either Columns or Rows. The box on the bottom will provide you with a summary of the selection.

Edit Graph – X-Axis
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You can set the content of the X-Axis using the database functions, as well as typing an X-Axis title. This screen also demonstrates the option of setting Line options such as colour and thickness. Further, you can set options for the labels displayed on the Axis.

Edit Graph – Y-Axis
[image: image111.png](T e e ot s S| 3 v | PAEa o]

Select aptions far the 1-Axis on your gragh.

(] Show Y1-#ixis Tite

1-85is T Fort.

Select opions for ne on the Y1-axis.

Setthe scale you would e to use onthis axis.

Miimum et Automatically
M et Automatically
ncremert: et Automatically

[ Logarithmic Scale

V1A e o





Similar to the X-Axis, on the Y-Axis you can set Title and any display option, such as scale, baseline value or if you need to, a Logarithmic scale. Additionally you have Reference Lines & Label Fonts available for selection.

Edit Graph – Plot Area
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The tab ‘Plot Area’ allows for changing of settings affecting the final presentation and layout of the graph. You can set background and border colours, decide on gridlines and data labels as well as mouse over dialogues to appear. Further you can decide on the colour scheme for any item in the displayed series.

Edit Graph – Legend
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In this tab you can decide if you want to display a Legend or not. If chosen, the location, background and border colours can be set, as well as the display font for any text.

21 Scheduling Workbooks

(N) File > Schedule…
With this version of the tool, Imperial College will introduce scheduling of workbooks. Scheduling is very similar to the scheduling of requests in the concurrent manager in Oracle Applications. 

Step 1 – General
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	Element
	Description

	What do you want to name this scheduled workbook?
	Please provide a meaningful name that you can search again when opening the saved results from the ‘Open Workbook’ dialogue.

	What description do you want for this scheduled workbook?
	You should provide a description for any saved workbook. As your list of saved workbooks grows, you will search more and more through your descriptions before running a workbook.

	Which worksheet(s) do you want to include in this scheduled workbook?
	If you have several sheets available, only select the sheets which matter – that should cut down on any unnecessary results saved to the database.


Step 2 – Parameter Values
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If you have Parameters on your selected sheets, you need to set the values accordingly. 
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	Should you require multiple result sets, try and amend the parameter to accept multiple values.


Step 3 – Schedule
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In this step you finally set your schedule.

	Element
	Description

	When do you want to schedule this workbook?
	The selection ‘Immediately’ should not really be required, as scheduling makes most sense if it is run out of normal working hours, thereby taking load of the application server. You schedules will be most likely allowed to fit into a period at night or on the weekend.

	How often do you want to repeat this schedule?
	If this is a one-off schedule, you should select ‘Never’. Otherwise time the number of repeats as a number of Days, Weeks, Months or Years. 

[image: image118.png]



Try to avoid setting a number of hours or minutes, as this will most likely cause additional server load.


	Scheduled workbooks save results each time they run. Do you want to keep all versions of results?
	Enabling ‘Yes’ there means that each scheduled run will store data in the database. Should you always require only the latest version of the data, please select ‘No’. That way the database is not loaded with unused data.

	How long do you want to keep the results?
	Delete results after ‘X’ days. This is the maximum amount of days you are permitted to keep results stored in the database. Your Discoverer administrator will set this maximum number on your user profile but you can always shorten that timeframe.


Clicking ‘Finish’ will set this scheduled report and you will need to get the results form the ‘Open Workbook’ dialogue filtering on ‘Scheduled Workbooks’ under the ‘View’ drop down.

22 WorkSheet Properties

(N) Edit > Worksheet Properties…
Similar to Workbook properties, worksheet properties allow for a detailed description of the contents of a worksheet. It is also possible to navigate to Worksheet Properties by right-clicking on a worksheet tab. In addition, the ‘Table Format’ functionality might be useful:
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The section Sheet content: Show null values as can be amended here to show a blank cell instead the value ‘NULL’. This is especially important for migrated workbooks (from the 4i version), as the standard function is ‘NULL’ and cannot be changed.

23 Discoverer Options

(N) Tools > Options…
Discoverer allows a user to change several options to influence the display of data and query performance. The changes are stored in the user profile on the server and hence they are independent of the machine used. 
In the following screenshots we will go through the most useful.
General

General options allow for setting the behaviour after the opening of a workbook, if used of Scheduled Workbooks and if you like to display graphic in wizards or not. You can also set the measurement unit for workbooks.
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Query Governor

The query governor is important for performance reasons. If you get frequent warning messages that the data might be incorrect because the limit of 10000 rows is exceeded, you can change this here.
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Sheet

The Sheet tab lets you choose some display options for data on your screen.
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Format

With this option you set the default values for all further items you use in your sheets. This might be especially helpful if you want to introduce a specific look & feel for reports you created.
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24 Advanced functionality

There are additional functions available in Oracle BI Discoverer, which are beyond the scope of a Beginners Manual and training course. Therefore find below a list of advanced topics not covered:

Calculations
There are a number of key functions and templates available for selection. Calculations can be useful for implementing concepts such as Key Performance Indicators, Departmental or Divisional Performance Measures and ‘If-then-else’ functionality.
Conditions
Advanced Conditions are possible involving the logical operators of AND/OR/NOT AND/NOT OR between each separate condition element. Also conditions can be based on other conditions, calculations and available rather than selected items.
These concepts and functions should be part of an advanced training course aimed to deepen the knowledge in the tool regarding analysis. However, as mentioned before, please do not be shy to try them out for yourself beforehand as Discoverer is a read only tool and you cannot break it.

25 The Menu Bar

File
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	Function
	Keyboard Shortcut
	Description

	New…
	Ctrl+N
	Creates a new workbook

	Open…
	Ctrl+O
	Opens existing workbook

	Close
	Alt+F+S
	Closes a workbook

	Save
	Ctrl+S
	Saves current status of the workbook using this name

	Save As…
	Al+F+A
	Saves current status of workbook allowing for a new name

	Export…
	Alt+F+E
	Opens an Export wizard for a structured export to all available file types

	Export to HTML
	Alt+F+T
	Exports the workbook contents to an HTML file

	Export to Excel
	Alt+F+R
	Exports the workbook contents to an Excel file

	Schedule
	Alt+F+D
	Allows scheduling the running of workbook at a specified time or at certain intervals.

Note: In this screenshot, this functionality is not available and availability depends on the Discoverer Administrator setting the relevant privileges.



	Share
	Alt+F+H
	Opens a wizard to allow sharing of a workbook with other Oracle Application Users or Responsibilities

	Page Setup
	Alt+F+U
	Sets up the page for printing and on-screen display

	Print Preview
	Alt+F+V
	Shows a print preview for the current workbook

	Print…
	Ctrl+P
	Opens a print wizard

	Workbook Properties…
	Alt+F+W
	Opens a dialogue for workbook properties. This is the place for a detailed description of the contents of a workbook.

	Exit
	Alt+F+X
	Quits Oracle BI Discoverer


Edit
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	Function
	Keyboard Shortcut
	Description

	Undo
	Ctrl+Z
	Takes back the last action

	Copy
	Ctrl+C
	Copies highlighted content to clipboard

	Delete
	Alt+E+D
	Deletes highlighted field from worksheet. This will be rarely used, for example to disable a calculation.

	Select All
	Ctrl+A
	Selects the contents of the worksheet

	Remove from Worksheet
	Delete
	Deletes highlighted field from worksheet. This is mostly used for removing unwanted Totals or columns from worksheets.

	Worksheet…
	Alt+E+W
	Opens the Worksheet Wizard

	Worksheet Layout…
	Alt+E+Y
	Opens the Worksheet Wizard on Worksheet Layout page

	Table…
	Alt+E+B
	Opens the Worksheet Wizard on Table Layout page

	Graph…
	Alt+E+G
	Opens the Graph Wizard

	Title…
	Alt+E+T
	Edits the Title Area

	Text Area…
	Alt+E+X
	Edits the Text Area

	Add Worksheet…
	Alt+E+A
	Adds another worksheet to the workbook

	Delete Worksheet…
	Alt+E+L
	Deletes worksheet from workbook

	Move Worksheet…
	Alt+E+M
	Moves worksheet to another position on workbook

	Rename Worksheet…
	Alt+E+H
	Renames current worksheet

	Duplicate Worksheet
	Alt+E+K
	Duplicates worksheet as either Table or Crosstab

	Worksheet Properties…
	Alt+E+E
	Opens a worksheet properties dialogue to provide additional descriptions for worksheets

	Find…
	Ctrl+F
	Searches content on worksheet using a Find dialogue

	Find Next
	F3
	Finds next search result on worksheet

	Find Previous
	Shift+F3
	Finds previous search result on worksheet


View
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View allows for general layout of the work desk.
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	Function
	Keyboard Shortcut
	Description

	Available Items Pane
	Alt+V+A
	Enables/Disables Available Items Pane

	Selected Items Pane
	Alt+V+D
	Enables/Disables Selected Items Pane

	Toolbar
	Alt+V+B
	Access the Standard Toolbar

	Status Bar
	Alt+V+S
	Enables/Disables the Status Bar, showing more detailed descriptions of mouse actions

	Title
	Alt+V+T
	Enables/Disables the Title Area

	Page Items
	Alt+V+P
	Enables/Disables Page Items (quick filters on item values)

	Table
	Alt+V+E
	Enables/Disables Data Table to be displayed

	Graph
	Alt+V+G
	Enables/Disables Graph for the data on the current worksheet

	Graph Placement
	Alt+V+L
	Allows for adjusting exact location of graph 

	Text Area
	Alt+V+X
	Enables/Disables Text Area


Format
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	Function
	Keyboard Shortcut
	Description

	Heading…
	Alt+O+H
	Formats a column heading

	Data…
	Alt+O+D
	Formats column data (item values)

	Columns
	Alt+O+C
	Formats Columns

	Item Formats…
	Alt+O+I
	Formats specific Item types (numeric, percent, text)

	Conditional Formats
	Alt+O+O
	Formats Conditions according to traffic light scheme, i.e. applying colours to predefined slots


Tools

[image: image129.png]File Edit View Fomat Help

Ve Se&
(s F O

=% % & % B BB )
e BB B

Avalable tems: gort.

4z % % Conditans.
Calulatons.
e T ——

Uist | @ Base Tables (81 1011°

Training.Outstanding Commitments & Amounts Billed

Detail

Supplar Name LIKE NITIAL ELECTRONICH, Gross it <> 0

07-DEC206, 09.3.05 1, Page Norber 1

& Sub Account Code
& Froject Code
£ Type Code

Parameters 1 [a0070278 7ootaea10 0.1 z00m lens for the CCTV Cameras | 11 o i e oo ol
SO Ar Checks 2 [sor0zrs roorazsas Supply ana £ Stentaghane @ 3 ron e | vezes_[o
3 [smrozrs Toorraa, Repai o vanil gate @ 3 = e | vezaa |8
©CI4P Expense Renor  Refresh Sheet
i txpenee T 4 [soozrs Tovzrsa0a, et gatesm @ 3 = e | veziea |8
o
Hpense Renoi 2 auto Refresh 5 [s00zrs = SECURITY S TEM MAINTENANCE C{11 3 nore | Fezae_ |8
B4R Holds 6 [z rovzssass Seounty Syem mantenanos cantact |11 " raon | CEE
©CIAP Invoice Distib Show SQL 7 [omerez rovzaas Vehile gae sare sages @ "o = I cerzaz_|a
®CIAP Invoice Paymen  Wanage Workbooks. o [szizesr rovzo0sas Equipmentfor Secuty elated Piart |11 "o raon [T otz o
Y4 Invaices o [z rovzo0sas Equipmentfor Secut elted Plart |11 "o raon [T careze [a] |
an7o060 = Securty Maimtanance Contad B o = R oooooe_ &
B4 Payment Distt optians. 0 il B
E 11 [07017a_[rooreesza Waimtanance of Sits Serurty Syaam |12 0 = | ooooos & |
12 07077 roorssen Repaie t Plant CETV Equpmant 40012 e =3 [T o000
13 [s0707a7 rooresTes 007077 - UNE 28 €71 Temy gnal] 2 e B [ oocooe &
14 [s00707a7 B 007077 -1NES 348 - SECURITY WA 2 e = R oocooe &
Selected flems:
15 [s00707a7 B 007077 -1NES 348 - SECURITY WA 12 e = & o oocooe &
T/ &0 16 [sorarer —[roozseces ety Unates amd Gorematies- 312 e I N D
o ol Encumbered Date 17 [sarorar rovzras Seourty Equipment Uparades 200707 12 e roen [ ooooo0_|s
&
[ % supgior N 16 0070787 o0z Flas Loading Bay Daor Sacurty Alarme] 12 o8 oare s o i
13h Supplier Name
5 SuPP 19 |40070352 700255603 ‘Security Maintenance contract 12 A8 |AGEA LEB. £l EEIE
[“HeaSuppler Number 20 |40072398. 700275198 Plant CCTV Camera Reapirs - 40072396 12 AE |AcBE HAN £l EEIE
SLeh Authorization Status 21 [a0072305 700200948 Plant CCTV Camers Maintenance 12 &= B3 A oo ooonon_[e
|2 Approved Date 22 [wowrzme rovzoe Prant CETV Camera Wantenance |12 5 oee v o D
L2 Gortract Manager Ja[avserer —[rovtiraaeit RICA e 1 for Requstion o 70011724 2 0 e e TN
Ly Orcerumncer 24 soricers [rooreeeez D e o IR R oo s
[ oeseriat 25 [arsea7 I CETV SveTEM SURPLY OF LensEs A1z e raon e weorzz_[o
eserption
[ " 26 [a0rzz083 To0teszas gl 1o 73608 warm i panel no 5] 12 e = [ o0&
- Reguisition Number 27 |40135263 700246088 CCTV Camera Houssing Replacement |12 0B DBAB 115 00 BE00Z2 B
i Creation Date 28 [a138773 o0 1600 Ganie Boom Operation Gatehouse Roof 12 2a noEn ies oo ooonon_[e
£ Company Codes. 20 [a0130281 B Eiortar wing osts rapaie B 0 = | oocooe &
£ Business Unit Code 30 [0tz ooz 700 Erower Samer Upgrads B o = e | Neoosk_[e
£ Department Code 31 [sre7ess Faoaeses WA Tumine Hal Securty Uparade |12 3 = [ Caoeoo |8
32 [awrezrz5 201020 CAMERR, 5 132HC 12V & o o000 A o0 ooo000 &~
£ Account Code q :





	Function
	Keyboard Shortcut
	Description

	Drill…
	Alt+T+D
	Drills to detail

Note: A drill path needs to be specified for this item by the Discoverer Administrator.



	Collapse
	Alt+T+A
	Collapses the drill down

Note: A drill path needs to be specified for this item by the Discoverer Administrator.



	Manage Links…
	Alt+T+K
	Allows to manage links to external worksheets

	Sort…
	Alt+T+S
	Sorts items ascending or descending, by groups or allows for hiding an item

	Conditions…
	Alt+T+N
	Adds analytical filters to a worksheet

	Calculations…
	Alt+T+C
	Adds calculated items to a worksheet

	Percentages
	Alt+T+P
	Adds percentages & sub-percentages to a worksheet

	Totals…
	Alt+T+L
	Adds totals and & subtotals to a worksheet

	Parameters…
	Alt+T+M
	Adds Parameters in front of a worksheet for selection before starting a query

	Parameter Values
	Alt+T+V
	Changes selected Parameter values. In the current example this is unavailable because no parameters are applied in this workbook.

	Refresh Sheet
	Alt+T+F
	Requeries the database for current worksheet

	Auto Refresh
	Alt+T+R
	If enables requeries the database automatically after each addition or change to the current worksheet

	Retrieve All Rows
	Alt+T+E
	If Query Governor limits the number of retrieved rows per query, this function will retrieve all available rows

	Show SQL…
	Alt+T+Q
	Shows the SQL statement that is generated by Discoverer for current worksheet and sent to the database on refresh of the query

	Manage Workbooks…
	Alt+T+W
	Manages all user owned workbooks for sharing, deletion and descriptions

	Manage Schedules…
	Alt+T+H
	Manages all User generated schedules for automated workbook querying

Note: This function must be enabled in the user privileges by the Discoverer Administrator.



	Options…
	Alt+T+O
	Sets all options for Oracle BI Discoverer on the user profile stored on the Application Server. With this users can log on at any machine with their customised Discoverer settings.


Help
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	Function
	Keyboard Shortcut
	Description

	Help Topics
	Alt+H+T
	Opens excellent HTML Oracle BI Discoverer help including topic index and search facility

	Oracle Technology Network
	Alt+H+O
	Pending internet access links directly to Oracle knowledge forum for Discoverer and other Oracle tools

	About Discoverer…
	Alt+H+A
	Shows version of Oracle BI Discoverer, login and EUL details as well as current RAM (PC working memory) availability


The Tool Bar

The tool bar provides quick and direct access to the most used functions within Oracle BI Discoverer. If you hold your mouse over a specific icon on any of the toolbars, you can trigger a tool tip with the name of that functionality. The following paragraphs will cover some of the most used icons.

New Workbook
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This function creates a new Workbook.
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	Oracle BI Discoverer Plus only allows having one workbook open at any one time. If you want to create a new workbook you will almost always see a dialogue that asks for saving any changes made to the currently open workbook. Always check that you do want to save any changes using the existing name for the workbook (keep in mind consequences for shared workbooks owned by your user), otherwise maybe use the ‘Save As…’ function to save the workbook with a different name.


Add Worksheet
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Here you can duplicate the current worksheet as a table or a crosstab.

Edit Table


[image: image134]
Left-clicking on this icon will take you to the Edit Table Worksheet Wizard.

Refresh
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Left-clicking on the inverted orange arrow will refresh the current worksheet.

Totals
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Here you can add new Totals quickly.

Percentages
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Here you can add new Percentages quickly.

Calculations
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Here you can add new calculations quickly.

Conditions
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Here you can add new conditions quickly.

Export to Excel

 SHAPE  \* MERGEFORMAT 



Left-clicking on this icon will export the contents of the worksheet to Excel.

Other Toolbars

In addition to the standard toolbar, Oracle BI Discoverer also provides a toolbar for quickly formatting worksheet content and graphs.

Format Toolbar
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Graph Toolbar
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Worksheet tabs context menu

Right-clicking on the worksheet tabs reveals the following options.

 SHAPE  \* MERGEFORMAT 



	Function
	Keyboard Shortcut
	Description

	Worksheet Properties…
	Alt+E
	Opens Worksheet Properties dialogue

	Delete Worksheet…
	Alt+L
	Delete currently selected worksheet from workbook

	Move Worksheet…
	Alt+M
	Moves selected worksheet to another position


Worksheet Properties

General

[image: image144.png]® Worksheet Properties

Narme:

Jdentifer.

Description

1

[This sheet shows the detal data





This tab allows for changing of the worksheet name and an addition of descriptive details on the functionality of this worksheet.
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	Please do not change identifiers anywhere in Oracle BI Discoverer (here and on the Workbook Properties dialogue. These are used to provide a unique reference for this specific worksheet/workbook and if changed can lead to a loss of the respective object.


Table Format
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Table headers

	Function
	Keyboard Shortcut
	Description

	Show column headings…
	Alt+O
	Shows column headings for all items on the worksheet (see example on the right side)

	Show row numbers…
	Alt+U
	Shows row numbers for all retrieved rows on the worksheet (see example on the right side)


Table data area

	Function
	Keyboard Shortcut
	Description

	Show vertical gridlines…
	Alt+V
	Shows vertical gridlines on worksheet (see example on the right side)

	Show horizontal gridlines…
	Alt+Z
	Shows horizontal gridlines on worksheet (see example on the right side)

	Gridline color
	Alt+G
	Selects gridline colour from colour palette


Sheet content

	Function
	Keyboard Shortcut
	Description

	Show null values as:
	Alt+N
	If there are no values retrieved this regulates the display of the data on the sheet

Note: It is highly advised not to select ‘0’ for null values to differentiate zero values from no data.
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Aggregation
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	It is recommended not to change this option.


Online Help

Oracle Discoverer BI Plus has an excellent help function in all dialogues as well as through the tool and menu bars. [image: image150.png]
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Items (Database Fields), 
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